Search

in:

Forum: Kega Fusion

Forums > Kega Fusion > Need comfirmation on possible SegaCD bugs

Need comfirmation on possible SegaCD bugs


sith-smasher posts: 328 3 stars Belgium
There seems to be interference in the FMV footage from Mary Shelly's Frankenstein (U) manifesting itself as horizontal lines in the FMV.
If someone has this game can you please check this. You need fusion 363 as it doesn't boot in 364. Get it from Snake's Fusion page on this site under older versions.

Certain elements are not displayed correctly in Marko (U) screens before and after levels, like the score being lower than it should be. Also the game over screen fucks up in a similar way where parts of the screen show fractured as if character data is not where it should be.

Either I got bad Bin/CUEs or there are bugs. If they are indeed bugs, please report it here so that Snake can fix them. Thx


Mary Shelly's Frankenstein (U) and Rise of the Dragon (U) have been confirmed to not work in 3.64
Use 3.63 for these. Snakey will fix that in the next release.


posts: 3 1 stars
As for MS Frankenstein, i've tried both redump.org & darkwater dumps, + numerous other versions & they all suffer from the lines through the intro/cutscenes. Even tried on multiple desktops/laptops. I know for a fact the redump & darkwater dumps are good. Another game that works fine in 363 but not in 364 is Corpse Killer 32X CD. Ultraverse Prime is just the opposite, not working in 363 but working fine in 364. F1 Circus CD i'm getting some weird artifacts/spots on the screen every now & again. Don't know about Marko, haven't played past the first level on that one. Thats about all i can think of, tried just about every release for US, PAL & alot of Japan & thats all the bugs i've ran up on.



sith-smasher posts: 328 3 stars Belgium
I have no issues with Corpse Killer 32X CD in 3.64


posts: 3 1 stars

Thanks, I'll have to test it out again. Currently testing Saturn games right now. Post back if you run up on anymore bugs. Does Frankenstein have the same issue through other emulators? I have not tried myself



xam925 posts: 57 3 stars
many multiple cd games dosen't work with recent bios,'cause the emu dosen't permit the "swap cd" option.

however, i've a list of segacd game's bug, i ll'post it later on a new topic.



King posts: 442 4 stars United_States
We need to get a list of non-working games going and perhaps post them in a sticky topic for Snake to see when he comes back? Of course, any non-working games will have to be verified not working regardless of perfect sync setting.

Also, you shouldn't be using the 2.00 MCD/SCD BIOS with Kega, only 1.X.



posts: 2 1 stars
Hi. Can someone try to duplicate this one for me?

I'm playing the original Out of this World on Sega CD (Heart of the Alien disk).

In the very beginning, when the cat drops down and starts chasing you, while trying to run left it seems the controls drop out randomly. Before and after the chase (when I can make it through the scene, which is difficult due to the controls dropping out) everything seems fine.

I'm not sure if this is an emulator issue or an issue with my system. I'm running Kega 3.64 and Windows 7. I have confirmed that the Genesis version does not exhibit the issue.



posts: 2 1 stars
I think I figured it out! Seems that having the controller set as a 6 button controller was causing the issue. Switched it to 3 and now there's no drop outs. Weird.



posts: 7 3 stars
Yes there is lines in FMV Frankenstein (U) in 3.63 and 3.64 and Rise of Dragon don't start up and crash in a looping in the firs bios screen on 3.64 only.



xam925 posts: 57 3 stars
demolition man :

sfx problems = emu issue,gens dosen't reproduce it

farenheit 32x :

icon for swapping disc dosen't showup on boot (bios USA 2.00), with bios 1.00 run fine.
sega cd normal version runs on both bios.

fhey area :

freeze after magic use in battle,when starting next attack turn,music continue playing

marko's magic football :

graphical glitch

Rise of the dragon :

with us bios 1.00 - feezes on sega logo (cd dosen't read anymore)
with bios 2.00 - emu restart after segacd logo

Sing!! Sega Game Music Presented By B.B. Queens :

dosen't boot

urusei yatsura :

feezes on sega logo (cd dosen't read anymore)


xam925 posts: 57 3 stars
That's my 2cent, i omitted the audio delay problems because is an issue given by the iso you're using.


sith-smasher posts: 328 3 stars Belgium
Please test with v1 BIOS. It is the only 'official' BIOS. Snake told me that they f**ked up a lot of stuff in later BIOSes.



King posts: 442 4 stars United_States
Don't use any of the 2.00 BIOS as they have issues. Use the 1.xx versions of BIOS when testing for issues.


posts: 60 3 stars Portugal
I don't know why you keep saying that, I've always used 2.00 BIOSes without any issues whatsoever.


xam925 posts: 57 3 stars

ok, i'll retry all the non working iso with bios 1.00,later i'll write wich's working or not


King posts: 442 4 stars United_States

Try going into the CD options and playing the game that way, the BIOS music keeps playing throughout the game. I think it's more safe to say that Kega emulates the model 1 Sega CD, not the model 2. :P People have brought it up in the past and Snake's mentioned it's a problem with the BIOS itself or something like that (been years so memory's kinda bad), so yeah.


posts: 60 3 stars Portugal
The only bug I've ever found was that going to the CD player with the 2.00 US BIOS the music keeps playing like you said but it stops immediately when the SEGA logo (the one with Sonic waving) appears so it does not happen in the game, also this bug never manifested with the European or Japanese 2.00 BIOS.


sith-smasher posts: 328 3 stars Belgium
The v1 BIOS is the only one by the original author of the thing. Later BIOSes have been 'hacked' and messed up in more ways than one by others at Sega.


Show posts:
Jump to forum:

Current Poll

All your base are belong to us
  • you bet!
  • what?!?
View Results
(Votes: 198)
Cookies must be allowed to vote

Online users

62 online users

Shoutbox

tomman, 09:00 CEST, 2014/04/08: (Note to myself: try Fusion on Debian Jessie...)
tomman, 09:00 CEST, 2014/04/08: Twitter? Social networking? HELL NO :P
Eidolon, 11:05 CET, 2014/03/22: Good to see you around, Steve! Just installing Fusion on my new laptop to enjoy a round of Lunar The Silver Star once again :)
zyrobs, 00:32 CET, 2014/03/08: I would but I can't figure out how Twitter works. Typical Web2.0 BS, optimized for stupid people...
King, 16:59 CET, 2014/02/26: Followed!
sith-smasher, 14:46 CET, 2014/02/22: A sign of Snakey; good that you are ok man! I hope life is treating you better than before. Peace.
Snake, 06:01 CET, 2014/02/20: Everybody in the world follow me on twitter @RealSteveSnake - just because.
King, 20:57 CET, 2014/02/17: SNAKKEEEEEEEE! :D
Snake, 19:21 CET, 2014/02/16: *waves*
King, 18:49 CET, 2014/02/15: Awesome, let him know we miss him and that we're glad he's okay! :)
RSS feed Wiki RSS feed Articles RSS feed Forums